EWARM and MQX training
This is the instructions for the hands-on technical session, AMF-IND-T0806, by IAR systems for Freescale DWF event in Toronto in November 2012.
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Preparations
Make sure you have the following software installed

· IAR Embedded Workbench for ARM (EWARM) version 6.40 or newer.
For these training sessions you can use either the full (EWARM), baseline (EWARM-BL) or the evaluation (EWARM-EV) editions. The 32K limited kickstart (EWARM-KS) will not be able to generate enough code for some of the examples!
· Freescale MQX for Kinetis, version 3.8.1

If you are missing any of these tools then you should install them at the beginning of this class in order to be doing the exercises. 
Both EWARM-EV and MQX can be found in the “Products” folder of the USB stick.

Tower system jumper settings

TWR-K60N512 Jumper Settings

· J6 must be left (2-3) for PHY clock
TWR-SER Jumper Settings
· J2 must be middle 3-4 for clock select
· J3 must be right 2-3 for CLKIN select
· J16 must be right 1-2 for USB host
· J12 must be 9-10 for Ethernet config, these are the middle pins
(If you need more jumpers then you can borrow from J5.)
Session 1: EWARM project management 

In this first session we describe project management and options in EWARM, using the Kinetis K60N512 TSI example project that comes bundled in with EWARM.

It is not required that you do this exercise, but it might be helpful for the coming exercises if you are not familiar with the IAR Embedded Workbench for ARM (EWARM).

Exercise 1a: Getting started with EWARM and TWR-K60
1. Start IAR Embedded Workbench for ARM (EWARM) from the start menu.
“Start menu” -> “Programs” -> “IAR Systems” -> “IAR Embedded Workbench for ARM …”
2. In Information center (EWARM Help menu -> Information center), select.
“Example projects” -> “Freescale” -> “Freescale Kinetis evaluation boards” -> “TSI”
Select/click on the “C/C++” icon. This will open a dialog where you specify, or create, a folder where all the source and project files will be copied. 
After you commit with “Choose”, EWARM will open up this TSI project in the folder you selected. For Windows 7 and Vista it is recommended that you use/create a folder in the “Document” tree.
3. In the Workspace Window, select the “tsi_k60_tower – RAM_128KB” project configuration.

Now we are almost ready to build, download and debug our example application. But the example is setup to use JLink or JTrace and not the “PE micro” debug driver we will use, so we need to change the debug driver selected. And since PE micro does not support SWD we will use the JTAG interface.
4. In the Workspace Window, right-click on “tsi_k60_tower – RAM_128KB” to bring up the context menu and select “Options…” to open up the project options dialog.
In the option dialog, make sure these options are set;

	Category
	Tab
	Option
	Value

	General options
	Library configuration
	Stdout/stderr
	Via semihosting

	Debugger
	Setup
	Driver
	PE micro

	PE micro
	Setup
	P&E Hardware interface type
	OSJtag

	PE micro
	Setup
	Interface
	JTAG


5. When done, click “OK” to commit and save any changes to the project options.

6. Now, in the Project menu, select “Download and Debug” (or press <CTTRL>+D) to download our example application onto the K60 board.
By default the project will be rebuilt if any changes were made since the last build.
7. Now we can have a look at the new views that are available in the debugger.
When done, exit the debugger by selecting “Stop Debugging” in the Debug menu or click on the icon with the red cross ([image: image1.png]X



).

Exercise 1b: Customizing your EWARM example
This TSI project uses a limited printf and is created to print via UART, and that is true for most of the Kinetis examples provided in EWARM. 
You can however easily change the project to use the IAR C printf and direct the output to the EWARM debugger (using semihosting). The only thing you have to do in order to get printf outputs to the IDE is to remove (or exclude) “printf.c” from the project. 
1. Right-click on printf.c in the “common” group in the Workspace Window and select “Options…”.
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2. Check the “Exclude from build” and click “OK” in the options dialog.
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3. Do a Download and Debug.

4. From the View menu, open the Terminal IO Window. You can do this while the application is still running to get to main. 

If you use the PE micro debugger you will notice that the printouts are rather slow. This is because the PE micro debug driver is not very fast.
If you have access to an I-jet or a JLink you can connect that debugger and compare the speed. For a Cortex-M device you can try this using either SWO or semihosting for stdout output.

5. Exit the debugger ([image: image4.png]X



).

Exercise 1c: Adding a Batch Build to our project
When building MQX libraries we will use the “Batch build” feature in EWARM. This exercise will show you have to create and use your own batch builds.
1. In the Project menu, select “Batch build…” (or just press <F8>).
2. In the Batch Build dialog you should see one batch build called All.
If you click “Edit…” you can see that this batch build will build all projects and their different configurations in a specific order. 
If you are in the Edit Batch Build dialog, then click “Cancel”.
3. In the Batch Build dialog, click “New…” to open the Edit Batch Build dialog.

4. Type in a name of your choice, for example “RAM builds” and select the three different RAM project configurations by clicking the “>” button.
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5. Drag the “tsi_k60_tower – RAM_128KB” project to the top to ensure that this project configuration is bult first. (The build order is not really important here. I just want you to know how to change the build order if you should need to do that in the future.)
6. Click “OK” to get back to the Batch Build dialog.

Now you have the option, with the help of the batch build tool, to build either all projects, or just all RAM linked projects. 

Session 2: EWARM and the MQX library projects

Here we will load the MQX library workspace and walk through of the workspace and project structure. We will also configure the libraries to use the debugger IO channel instead of the UART. 

From the MQX Getting Started Guide we have:

“The standard input and output channel can be redirected to the DebugIO driver allowing processor to communicate with computer via the debugger probe. The MQX RTOS currently supports ARM CortexM Semihost and ITM technologies. Note that the communication has to be properly set up in the debugger on the PC host side.”
We know how to configure the application project to use semihosted debug IO for the PE micro debugger. In the next exercise we will configure MQX to redirect IO to the debug driver, using semihosting. In MQX this is done differently compared the example projects that are included in EWARM, for example the TSI example above.
Exercise 2a: Configure MQX to use semihosted (debugger) IO instead of UART

This part has to be configured in the MQX libraries used by our application. 
1. In the EWARM File menu, select Open -> Workspace and browse to the MQX library workspace for TWR-K60N512. The workspace file is called “build_libs.eww” and the default path for this library project file is:
C:\Freescale\Freescale MQX 3.8\config\twrk60n512\iar\build_libs.eww
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2. We will start by configuring the libraries to use the debugger as printf output channel:
In “user_config.h”, set BSPCFG_ENABLE_IODEBUG to ‘1’
In “twrk60n512.h”, set BSP_DEFAULT_IO_CHANNEL to “iodebug:”.

Tips; If you expand (click the ‘+’ sign) for example the file “Generic IO Drivers -> cm -> cm.c” you will see a list of all the files this C file depends on. In this list you can double-click user_config.h and twrk60n512.h to make sure that you are editing the correct version on these files. As you remember, these files are copied to other folders after a build and it is easy to edit the wrong configuration file.

For an example on how edit the configuration files, see “Session1_1.txt”.


3. Now we will use Batch Build to build all projects that needs to be rebuilt.
In the Project menu, select “Batch build…” to open the Batch Build dialog.


4. Now we have the option to build “All” libraries, or only the “Debug” or “Release” libraries. We also have the option to do a Make (only translate files needed since our last build), or Rebuild All.

Highlight “Debug” and click “Make” to only build our debug libraries.
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Rebuilding the MQX libraries will take some time so while this is being done we will have a look at the MQX library project options. Of most interest here are these options.
	Category
	Tab
	Option
	Value

	General options
	Target
	Processor variant
	Cortex-M4
or
MK60DN512Zxxx10

	General options
	Output
	Output file
	Library

	General options
	Library Configuration
	stdout/stderr
	Via semihosting

	C/C++ Compiler
	Optimizations
	Level
	None or Low

	Build Actions
	
	Post-build command line
	<lib>.bat

	Library Builder
	
	Output file
	Override 


Session 3: Setting up a MQX application

Now that we built our MQX libraries we will create an application that uses MQX and prints messages to our Terminal IO Window in the debugger.

Exercise 3a: Creating our own MQX based application

1. Open a new instance of EWARM.
Make sure that no project is loaded. If you have one or more projects loaded in your workspace, then select: File -> Close Workspace.

2. Create a new, empty, project:  Project -> Create new project -> Empty project
and click “OK”.

You will now have to specify the project location and name and for this exercise we will use:
Location: C:\Freescale\Freescale MQX 3.8\MyProjects\training\
Name: prj_1.ewp
Click “Save” close the dialog and commit to this name and location.
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3. We will also create a name for our new workspace and save it to the same location. 
For this, go to: File -> Save Workspace.
Use the Workspace name “Project-1.eww” and commit by clicking “Save”.

4. Now we will add a Group containing MQX libraries to our project structure.
Right-click on “prj_1 – Debug” and select: Add -> Add Group…
Type in “MQX” and click “OK”.

5. Open Windows Explorer and browse to: C:\Freescale\Freescale MQX 3.8\lib\twrk60n512.iar\bsp\.
Drag-and-drop the “bsp_twrk60n512_d.a” library in our newly created MQX group in EWARM.

In the same way, drag-and-drop “psp_twrk60n512_d.a” from C:\Freescale\Freescale MQX 3.8\lib\twrk60n512.iar\psp\ to our MQX group.

6. Now it is time to add our own C source where we can write our application code.
For this, create a new file from the File menu (or do <CTRL>+N) and then Save (or <CTRL>+S).
Name the file myApp.c and make sure it will be located in C:\Freescale\Freescale MQX 3.8\MyProjects\training\ before committing with “Save”.
7. To actually add this C file to our project, in the Workspace Window, right-click on the project “prj_1 – Debug” and select: Add -> Add “myApp.c”.
You should now be able to see that myApp.c have been added to our project tree in the Workspace Window.
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8. The code we will add to this source file is very similar to what the Hello2 MQX example project application contains. The only thing is that it is cut down to a minimum. This in order to see what we really need for a simple application like this.
For the code to add to myApp.c, see “Session2_1.txt”.
9. Now we are almost ready to build, but before we do we need to setup the project options as specified in the table below. 
Before we set the project options, copy the “intflash.icf” linker configuration file from the USB stick to the location of your project, that is;
 “C:\Freescale\Freescale MQX 3.8\MyProjects\training”
	Category
	Tab
	Option
	Value

	General options
	Target
	Processor variant
	MK60DN512Zxxx10

	General options
	Library Configuration
	Low-level interface
	Semihosted

	General options
	Library Configuration
	stdout/stderr
	Via semihosting

	C/C++ Compiler
	Optimizations
	Level
	Low

	C/C++ Compiler
	Preprocessor
	Additional include directories
	$PROJ_DIR$\..\..\lib\twrk60n512.iar
$PROJ_DIR$\..\..\lib\twrk60n512.iar\psp

	Linker
	Config
	Linker configuration file
	$PROJ_DIR$\intflash.icf
(intflash.icf can be found on the USB)

	Linker
	List
	Generate linker map file
	<Checked>

	Debugger
	Setup
	Driver
	PE micro

	Debugger
	Download
	Verify download
	<Checked>

	Debugger
	Download
	Use flash loader(s)
	<Checked>

	Debugger 
	Plugins
	MQX
	<Checked>

	PE micro
	Setup
	P&E Hardware interface type
	OSJtag

	PE micro
	Setup
	Interface
	JTAG


10. When done, click “OK” and do a “Download and debug”  ([image: image10.png]


).
11. After the code has downloaded and the debugger stopped the application at ‘main’, open up the Terminal I/O Window from the “View” menu.

12. Drag-and-drop the Terminal I/O Window in the Disassembly Window. 
This will create a multiple view where you can switch between Terminal I/O and Disassembly View in the same Window (tabs at the bottom).

13. Run ([image: image11.png]


) and watch the Terminal I/O View print out the messages from the two tasks we have in this application.

14. Halt the application and from the View menu select Registers.
In the Register Window you will be able to both examine and set different registers and bits for the K60N512. As you can see, all the Registers are nicely grouped to make it easy to find the register(s) you are interested in.

15. Exit the debugger ().

Exercise 3b: Adding MQX BSP and PSP libraries to our application workspace

To not have to have switch between different workspaces, library and application, we can add the MQX library projects we need to our own application workspace.
1. In the workspace where we have our application project, select: 
Project menu -> Add Existing Project…
2. Browse to the “mqx\build\iar\” folder and select bsp_twrk60n512.ewp project and click “Open”.

3. Do the same steps above to add the “psp_twrk60n512.ewp” PSP library project.
Your Workspace should 
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Note: that adding the library projects to this Workspace does not automatically include the libraries we build to the application project. We still need to have them added to the different application projects. Add the library a project just makes it easier to modify and build the different libraries and the application project from within the same Workspace.

Exercise 3c: Creating our own set of batch builds.

It would be convenient to be able to easily build both the libraries and the application now that we have all projects in the same workspace. And we will do this by adding one or more Batch Builds.

1. In the Project menu, select “Batch build…”.

2. Click “New…”

3. Name the new batch build “MyApp Debug” and add the three debug project configurations.
Make sure that the BSP and PSP libraries are built before your application. If the application is not last in the list, then you can just drag it to the last position.
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4. Click “OK”, and then, with the “MyApp Debug” selected, click “Make” to rebuild only the parts of the libraries and application that have changed since the last build.
5. Download and debug to make sure that everything works as expected.
Session 4: Adding a second MQX application to our workspace

Now we will add the MQX webserver application to our workspace and configure our network to be able to view the demo application in a web browser.
Exercise 4a: Adding the webserver project to our workspace.

We can also add (or create) a second application to our current Workspace. We will for this exercise not create a new application but simply add the HTTP server application already in MQX.

1. In EWARM, select Project -> Add Existing Project…

2. In the Add Existing Project… dialog, browse to the RTCD webserver example and click “Open”.
C:\Freescale\Freescale MQX 3.8\rtcs\examples\httpsrv\iar\httpsrv_twrk60n512.ewp
3. Since this webserver uses not only the BPS and PSP libraries, but also the RTCE library we like to add that project to our Workspace as well. To do this, again select “Add existing project…” from the Project menu in EWARM.

4. Browse to the “rtcs\build\iar” folder and select “rtcs_twrk60n512.ewp”.

5. Now we will create an additional batch build that will build our webserver application and also the needed MQX libraries for this project. For this, select “Batch build…” from the EWARM Project menu.
6. Click “New…” and name the batch build to for example “MyWebserver Debug” and add the Debug configurations of BPS, PSP, RTCS and webserver application projects to this batch build.
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Note: There are two configurations for the webserver project. One for RAM and one for Flash memory. Only the Flash configuration will be able to build since we don’t have enough RAM for everything to fit into the RAM memory.

7. Click “OK” and do a “Make” after making sure that your “MyWebserver Debug” batch build is selected (highlighted) in the Batch Build dialog.
8. Before we run our webserver we need to configure the network on the machine where we have the web browser where we like to view the demo.
In the config.h file the webserver IP address is specified and we need to make sure that our network is setup so that we can browse that IP address. What we are looking for is the definition of ENET_IPADDR  and we can see that it is setup to use address 192.168.1.4.
   ENET_IPADDR  IPADDR(192,168,1,4)


9. To change the IP address and network, open “Properties” of your IP (version 4) and set:
IP address: 192.168.1.1
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.4
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10. Now we can do “Download and debug”. Before we run we should make sure that our Ethernet cable is connected to our machine and the serial module on the tower system. When this is done we can run (Go) our application

11. Start your favorite browser and type in 192.168.1.4 and view the webserver running on your tower system.
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Exercise 4b: Auto rebuild modified web pages
The webserver example is displaying a number of web pages and all of these pages are translated into C arrays that are included in our application. If we modify any of these web pages and want to try them out, the  we must first convert them into C arrays. For this Freescale and MQX is providing a tool called “mktfs.exe”. And there is also a mktfs.bat file located in the webserver HTTP server example.
The idea is to run the mktfs.bat before building the webserver example in order to regenerate the new C arrays containing all the different web pages.
We can automate this process by adding a pre-build command to our webserver project.

1. In “rtcs\examples\httpsrv”, create a bat file called “mktfsEW.bat” with the following content:
cd %1\..
..\..\..\tools\mktfs.exe web_pages
2. In your httpsrv_twrk60n512 project, select Options…

3. In “Build Actions” set the Pre-build command to: 
"$PROJ_DIR$\..\mktfsEW.bat" "$PROJ_DIR$"
